aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-25 21:49:59 +0200
committerAdrian Kummerländer2014-05-25 21:49:59 +0200
commitc5a11763985172f54d0da8a2a2778f882f3656e5 (patch)
tree2a2eb165424ecf91b0b229d36de1da79e4bdbaa3 /CMakeLists.txt
parentbf88fb942d624f40218716d375744aa14b3406a8 (diff)
downloadInputXSLT-c5a11763985172f54d0da8a2a2778f882f3656e5.tar
InputXSLT-c5a11763985172f54d0da8a2a2778f882f3656e5.tar.gz
InputXSLT-c5a11763985172f54d0da8a2a2778f882f3656e5.tar.bz2
InputXSLT-c5a11763985172f54d0da8a2a2778f882f3656e5.tar.lz
InputXSLT-c5a11763985172f54d0da8a2a2778f882f3656e5.tar.xz
InputXSLT-c5a11763985172f54d0da8a2a2778f882f3656e5.tar.zst
InputXSLT-c5a11763985172f54d0da8a2a2778f882f3656e5.zip
Implemented basic external "execute" function
* enables execution of external programs ** second parameter is passed to stdin ** stdout is captured and returned ** based on booost::process * this was implemented to enable access to external content preprocessors such as markdown
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e09c096..442c215 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ set(
src/function/read_xml_file.cc
src/function/read_directory.cc
src/function/transform.cc
+ src/function/execute.cc
src/support/filesystem_context.cc
src/support/stylesheet_parameter_guard.cc
src/support/xalan_string.cc