aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-06 20:12:11 +0200
committerAdrian Kummerländer2014-05-06 20:12:11 +0200
commite17ba6dde7588f717bc5e79b3cb64cddd73d6173 (patch)
tree537d9beef3960b31ab39ebf80d30ed56c69166a8 /CMakeLists.txt
parent9aad4dffd9c8b0fde534b3abc3c27875547423fa (diff)
downloadInputXSLT-e17ba6dde7588f717bc5e79b3cb64cddd73d6173.tar
InputXSLT-e17ba6dde7588f717bc5e79b3cb64cddd73d6173.tar.gz
InputXSLT-e17ba6dde7588f717bc5e79b3cb64cddd73d6173.tar.bz2
InputXSLT-e17ba6dde7588f717bc5e79b3cb64cddd73d6173.tar.lz
InputXSLT-e17ba6dde7588f717bc5e79b3cb64cddd73d6173.tar.xz
InputXSLT-e17ba6dde7588f717bc5e79b3cb64cddd73d6173.tar.zst
InputXSLT-e17ba6dde7588f717bc5e79b3cb64cddd73d6173.zip
Added basic external read file function test case
* ... as a test of how well we are able to test DOM structures * required change of constructDocument visibility
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 565b3cb..3333c26 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ add_executable(
src/support/filesystem_context.cc
src/support/dom/document_cache.cc
src/support/dom/document_cache_item.cc
+ tests/function_read_file.cc
)
target_link_libraries(
@@ -29,4 +30,5 @@ target_link_libraries(
xerces-c
boost_system
boost_filesystem
+ gtest
)