aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-02 22:06:37 +0200
committerAdrian Kummerländer2014-05-02 22:06:37 +0200
commite5ed418907f09bf8905463f42a44593d51159bc9 (patch)
tree25d70d23625877946486ce8d46d7c4fb98a836f9 /CMakeLists.txt
parente9c4e2b716798002c9ccbf96ee509eb91ad56553 (diff)
downloadInputXSLT-e5ed418907f09bf8905463f42a44593d51159bc9.tar
InputXSLT-e5ed418907f09bf8905463f42a44593d51159bc9.tar.gz
InputXSLT-e5ed418907f09bf8905463f42a44593d51159bc9.tar.bz2
InputXSLT-e5ed418907f09bf8905463f42a44593d51159bc9.tar.lz
InputXSLT-e5ed418907f09bf8905463f42a44593d51159bc9.tar.xz
InputXSLT-e5ed418907f09bf8905463f42a44593d51159bc9.tar.zst
InputXSLT-e5ed418907f09bf8905463f42a44593d51159bc9.zip
Changed external functions to enable global installation
* up until now all external functions were locally installed to a specific XalanTransformer instance contained within a TransformationGuard instance ** this had to change as I planned to add a "execute-transformation" function based on TransformationGuard which would have led to recursive self-instantiation ** global external functions have to be thread-safe * as global external function can not be provided with a reference to a transformation-specific FilesystemFacade instance, the working path is now determined using xalan::Locator ** currently using pointer arithmetics on XMLCh* to remove the "file://" prefix of the URI returned by locator->getSystemId(), may be unsafe * added compilation unit for PlattformGuard as it now contains function installation in addition to plattform lifetime management
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02a9b79..fd14740 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ include_directories(
add_executable(
test
test.cc
+ src/plattform_guard.cc
src/transformation_facade.cc
src/function/read_file.cc
src/function/read_xml_file.cc