aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-04-18 13:50:57 +0200
committerAdrian Kummerländer2014-04-18 13:50:57 +0200
commite886ac3a4f2dacc79cf174b1257146fd91bf6b7c (patch)
treebbb85fe0b889e4b979e5c1cdffda473508c4f236 /CMakeLists.txt
parentf2e8939180d42b9f233b326c9dea34a02fcf9859 (diff)
downloadInputXSLT-e886ac3a4f2dacc79cf174b1257146fd91bf6b7c.tar
InputXSLT-e886ac3a4f2dacc79cf174b1257146fd91bf6b7c.tar.gz
InputXSLT-e886ac3a4f2dacc79cf174b1257146fd91bf6b7c.tar.bz2
InputXSLT-e886ac3a4f2dacc79cf174b1257146fd91bf6b7c.tar.lz
InputXSLT-e886ac3a4f2dacc79cf174b1257146fd91bf6b7c.tar.xz
InputXSLT-e886ac3a4f2dacc79cf174b1257146fd91bf6b7c.tar.zst
InputXSLT-e886ac3a4f2dacc79cf174b1257146fd91bf6b7c.zip
Added cmake build instructions
* changed relative paths of input files to accomodate builds inside a separate directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..e98ef8a
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required(VERSION 2.8)
+project(InputXSLT)
+
+set(
+ CMAKE_CXX_FLAGS
+ "-std=c++11 -W -Wall -Wextra -Winline -pedantic"
+)
+
+include_directories(
+ src/
+)
+
+add_executable(
+ test
+ test.cc
+)
+
+target_link_libraries(
+ test
+ xalan-c
+ xerces-c
+)