aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2022-12-29 11:27:27 +0100
committerAdrian Kummerlaender2022-12-29 11:27:27 +0100
commit7d41e83b4f62c8f79be4a0e984a11941d55e66dc (patch)
tree11a2bf33ce4729f063e78005a8c0fba74bf51026 /flake.nix
parent6d353960542e5c95f29d45b9359db25945a414a4 (diff)
downloadInputXSLT-7d41e83b4f62c8f79be4a0e984a11941d55e66dc.tar
InputXSLT-7d41e83b4f62c8f79be4a0e984a11941d55e66dc.tar.gz
InputXSLT-7d41e83b4f62c8f79be4a0e984a11941d55e66dc.tar.bz2
InputXSLT-7d41e83b4f62c8f79be4a0e984a11941d55e66dc.tar.lz
InputXSLT-7d41e83b4f62c8f79be4a0e984a11941d55e66dc.tar.xz
InputXSLT-7d41e83b4f62c8f79be4a0e984a11941d55e66dc.tar.zst
InputXSLT-7d41e83b4f62c8f79be4a0e984a11941d55e66dc.zip
Replace default.nix by flakeHEADmaster
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..76820d8
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,29 @@
+{
+ description = "InputXSLT";
+
+ inputs = {
+ nixpkgs.url = github:NixOS/nixpkgs/nixos-21.05;
+ };
+
+ outputs = { self, nixpkgs, ... }: {
+ defaultPackage.x86_64-linux = let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs { inherit system; };
+
+ in pkgs.stdenv.mkDerivation rec {
+ name = "input-xslt";
+
+ src = pkgs.lib.cleanSource ./.;
+
+ buildInputs = with pkgs; [
+ cmake boost xalanc xercesc discount
+ ];
+
+ meta = {
+ description = "InputXSLT";
+ homepage = https://tree.kummerlaender.eu/projects/xslt/input_xslt/;
+ license = pkgs.lib.licenses.asl20;
+ };
+ };
+ };
+}