aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt31
1 files changed, 26 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3333c26..53fa29c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,9 +10,9 @@ include_directories(
src/
)
-add_executable(
- test
- test.cc
+add_library(
+ InputXSLT
+ STATIC
src/plattform_guard.cc
src/transformation_facade.cc
src/function/read_file.cc
@@ -21,14 +21,35 @@ add_executable(
src/support/filesystem_context.cc
src/support/dom/document_cache.cc
src/support/dom/document_cache_item.cc
- tests/function_read_file.cc
)
-target_link_libraries(
+add_executable(
+ example
+ example.cc
+)
+
+add_executable(
test
+ test.cc
+ tests/function_read_file.cc
+)
+
+set(
+ Libraries
+ InputXSLT
xalan-c
xerces-c
boost_system
boost_filesystem
+)
+
+target_link_libraries(
+ example
+ ${Libraries}
+)
+
+target_link_libraries(
+ test
gtest
+ ${Libraries}
)