aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 14 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53fa29c..b6229ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,9 +10,18 @@ include_directories(
src/
)
-add_library(
+set(
+ Libraries
InputXSLT
- STATIC
+ xalan-c
+ xerces-c
+ boost_system
+ boost_filesystem
+ boost_program_options
+)
+
+set(
+ Sources
src/plattform_guard.cc
src/transformation_facade.cc
src/function/read_file.cc
@@ -24,32 +33,17 @@ add_library(
)
add_executable(
- example
- example.cc
-)
-
-add_executable(
test
test.cc
- tests/function_read_file.cc
)
-set(
- Libraries
+add_library(
InputXSLT
- xalan-c
- xerces-c
- boost_system
- boost_filesystem
-)
-
-target_link_libraries(
- example
- ${Libraries}
+ STATIC
+ ${Sources}
)
target_link_libraries(
test
- gtest
${Libraries}
)