aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..76820d8
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,29 @@
+{
+ description = "InputXSLT";
+
+ inputs = {
+ nixpkgs.url = github:NixOS/nixpkgs/nixos-21.05;
+ };
+
+ outputs = { self, nixpkgs, ... }: {
+ defaultPackage.x86_64-linux = let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs { inherit system; };
+
+ in pkgs.stdenv.mkDerivation rec {
+ name = "input-xslt";
+
+ src = pkgs.lib.cleanSource ./.;
+
+ buildInputs = with pkgs; [
+ cmake boost xalanc xercesc discount
+ ];
+
+ meta = {
+ description = "InputXSLT";
+ homepage = https://tree.kummerlaender.eu/projects/xslt/input_xslt/;
+ license = pkgs.lib.licenses.asl20;
+ };
+ };
+ };
+}