aboutsummaryrefslogtreecommitdiff
path: root/pkgs/InputXSLT.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-06-05 18:40:30 +0200
committerAdrian Kummerlaender2018-06-05 18:40:30 +0200
commit190fbe661949a64e01ccc9e22665707d898cf932 (patch)
tree21152f7a2f9653413ad55abdc416107d0cddef21 /pkgs/InputXSLT.nix
parent538813a88db3b7a7b260403790b0f6bd2e0b8ee9 (diff)
downloadOverview-190fbe661949a64e01ccc9e22665707d898cf932.tar
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.gz
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.bz2
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.lz
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.xz
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.zst
Overview-190fbe661949a64e01ccc9e22665707d898cf932.zip
Nixify build process
Diffstat (limited to 'pkgs/InputXSLT.nix')
-rw-r--r--pkgs/InputXSLT.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/pkgs/InputXSLT.nix b/pkgs/InputXSLT.nix
new file mode 100644
index 0000000..a85bc37
--- /dev/null
+++ b/pkgs/InputXSLT.nix
@@ -0,0 +1,20 @@
+{ stdenv, fetchFromGitHub, cmake, boost, xalanc, xercesc, discount }:
+
+stdenv.mkDerivation rec {
+ name = "InputXSLT";
+
+ src = fetchFromGitHub {
+ owner = "KnairdA";
+ repo = "InputXSLT";
+ rev = "master";
+ sha256 = "1j9fld3sh1jyscnsx6ab9jn5x6q67rjh9p3bgsh5na1qrs40dql0";
+ };
+
+ buildInputs = [ cmake boost xalanc xercesc discount ];
+
+ meta = with stdenv.lib; {
+ description = "InputXSLT";
+ homepage = https://github.com/KnairdA/InputXSLT/;
+ license = stdenv.lib.licenses.asl20;
+ };
+}