aboutsummaryrefslogtreecommitdiff
path: root/pkgs/StaticXSLT.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-06-05 18:40:30 +0200
committerAdrian Kummerlaender2018-06-05 18:40:30 +0200
commit190fbe661949a64e01ccc9e22665707d898cf932 (patch)
tree21152f7a2f9653413ad55abdc416107d0cddef21 /pkgs/StaticXSLT.nix
parent538813a88db3b7a7b260403790b0f6bd2e0b8ee9 (diff)
downloadOverview-190fbe661949a64e01ccc9e22665707d898cf932.tar
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.gz
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.bz2
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.lz
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.xz
Overview-190fbe661949a64e01ccc9e22665707d898cf932.tar.zst
Overview-190fbe661949a64e01ccc9e22665707d898cf932.zip
Nixify build process
Diffstat (limited to 'pkgs/StaticXSLT.nix')
-rw-r--r--pkgs/StaticXSLT.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/StaticXSLT.nix b/pkgs/StaticXSLT.nix
new file mode 100644
index 0000000..3caee06
--- /dev/null
+++ b/pkgs/StaticXSLT.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+ name = "StaticXSLT";
+
+ src = fetchFromGitHub {
+ owner = "KnairdA";
+ repo = "StaticXSLT";
+ rev = "master";
+ sha256 = "17gd181cw9yyc4h1fn7fikcgm8g7fdwm7d7fxwib4aynm18kwqad";
+ };
+
+ installPhase = ''
+ mkdir $out
+ cp -r * $out/
+ '';
+
+ meta = with stdenv.lib; {
+ description = "StaticXSLT";
+ homepage = https://github.com/KnairdA/StaticXSLT/;
+ license = stdenv.lib.licenses.mit;
+ };
+}