aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..6f297a7
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,19 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation rec {
+ name = "env";
+ env = buildEnv { name = name; paths = buildInputs; };
+
+ buildInputs = let
+ InputXSLT = pkgs.callPackage ./pkgs/InputXSLT.nix {};
+ generate = pkgs.callPackage ./pkgs/generate.nix {};
+ preview = pkgs.callPackage ./pkgs/preview.nix {};
+ in [
+ generate
+ preview
+ InputXSLT
+ wget
+ pandoc
+ highlight
+ ];
+}