aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt35
1 files changed, 22 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 763be29..fbbb8fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,41 +3,50 @@ project(SimpleParser)
set(
CMAKE_CXX_FLAGS
- "-std=c++14 -W -Wall -Wextra -Winline -pedantic"
+ "${CMAKE_CXX_FLAGS} -std=c++17 -W -Wall -Wextra -Winline -pedantic"
)
add_library(
SimpleParser
SHARED
- src/nodes.cc
- src/tree.cc
- src/utils.cc
- src/parser.cc
+ src/nodes.cc
+ src/tree.cc
+ src/utils.cc
+ src/parser.cc
)
add_executable(
tests
- test.cc
+ test.cc
)
add_executable(
clc
- clc.cc
+ clc.cc
)
target_link_libraries(
tests
- SimpleParser
- gtest
+ SimpleParser
+ gtest
)
target_link_libraries(
clc
- SimpleParser
- boost_program_options
+ SimpleParser
+ boost_program_options
+)
+
+install(
+ TARGETS
+ clc
+ DESTINATION
+ bin
)
add_custom_command(
- TARGET tests
- POST_BUILD COMMAND ./tests
+ TARGET
+ tests
+ POST_BUILD COMMAND
+ ./tests
)