aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..429d61a
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,25 @@
+{
+ description = "static site generator for blog.kummerlaender.eu";
+
+ inputs = {
+ nixpkgs.url = github:NixOS/nixpkgs/nixos-21.05;
+ pkgs-personal.url = git+https://code.kummerlaender.eu/pkgs;
+ };
+
+ outputs = { self, nixpkgs, pkgs-personal, ... }: let
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ in {
+ devShell.x86_64-linux = pkgs.mkShell {
+ buildInputs = [
+ pkgs.pandoc
+ pkgs.highlight
+ pkgs-personal.katex-wrapper
+ pkgs-personal.make-xslt
+ ];
+
+ shellHook = ''
+ export NIX_SHELL_NAME="blog.kummerlaender.eu"
+ '';
+ };
+ };
+}