aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-10-11 22:34:42 +0200
committerAdrian Kummerlaender2018-10-11 22:34:42 +0200
commit65aca58ba4167a8e4dfeb7274a5a43fb7343b2f8 (patch)
treebec77504f4967503ecf72ddfdde4b2920b3ca47b /CMakeLists.txt
parent4e8921427d4dd6717ff4ef262e7c04bbbd21a906 (diff)
downloadboltzbub-65aca58ba4167a8e4dfeb7274a5a43fb7343b2f8.tar
boltzbub-65aca58ba4167a8e4dfeb7274a5a43fb7343b2f8.tar.gz
boltzbub-65aca58ba4167a8e4dfeb7274a5a43fb7343b2f8.tar.bz2
boltzbub-65aca58ba4167a8e4dfeb7274a5a43fb7343b2f8.tar.lz
boltzbub-65aca58ba4167a8e4dfeb7274a5a43fb7343b2f8.tar.xz
boltzbub-65aca58ba4167a8e4dfeb7274a5a43fb7343b2f8.tar.zst
boltzbub-65aca58ba4167a8e4dfeb7274a5a43fb7343b2f8.zip
Setup basic periodic channel example
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4248a32..bf8dc7b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,7 @@ add_library(
src/lbm.cc
src/fluid_buffer.cc
src/boundary_conditions.cc
+ src/box_obstacle.cc
)
target_compile_features(
@@ -39,10 +40,19 @@ target_link_libraries(
add_executable(
lid_driven_cavity_with_obstacles
lid_driven_cavity_with_obstacles.cc
- src/box_obstacle.cc
)
target_link_libraries(
lid_driven_cavity_with_obstacles
boltzbub
)
+
+add_executable(
+ channel
+ channel.cc
+)
+
+target_link_libraries(
+ channel
+ boltzbub
+)