aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-06-11 22:10:51 +0200
committerAdrian Kummerlaender2018-06-11 22:10:51 +0200
commite698d1593cc4407b28f324ee930d8c83a8589955 (patch)
treec6d584f9accdca607897bd098d977a3258aa69f6 /CMakeLists.txt
parent1e8ab0202cf999dd19e61ea62d479e1cc4e35e93 (diff)
downloadboltzbub-e698d1593cc4407b28f324ee930d8c83a8589955.tar
boltzbub-e698d1593cc4407b28f324ee930d8c83a8589955.tar.gz
boltzbub-e698d1593cc4407b28f324ee930d8c83a8589955.tar.bz2
boltzbub-e698d1593cc4407b28f324ee930d8c83a8589955.tar.lz
boltzbub-e698d1593cc4407b28f324ee930d8c83a8589955.tar.xz
boltzbub-e698d1593cc4407b28f324ee930d8c83a8589955.tar.zst
boltzbub-e698d1593cc4407b28f324ee930d8c83a8589955.zip
Add CMake build instructions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..a5b185d
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.10)
+project(boltzbub)
+
+set(
+ CMAKE_CXX_FLAGS
+ "${CMAKE_CXX_FLAGS} -std=c++1z -W -Wall -Wextra -Winline -pedantic"
+)
+
+include_directories(
+ src/
+)
+
+add_executable(
+ boltz
+ boltz.cc
+)