aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..087712a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,16 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation rec {
+ name = "boltzbub-env";
+ env = buildEnv { name = name; paths = buildInputs; };
+
+ buildInputs = [
+ git
+ gcc
+ cmake
+ ];
+
+ shellHook = ''
+ export NIX_SHELL_NAME="${name}"
+ '';
+}