aboutsummaryrefslogtreecommitdiff
path: root/boltzgen.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-11-12 22:59:03 +0100
committerAdrian Kummerlaender2019-11-12 22:59:03 +0100
commit2dba6db0c94ccb260f3e9345b25146ce75ccea9a (patch)
treefaa6fc942905f05f082cef3dbe82b98f71b8d472 /boltzgen.nix
parent155c630827bae820412d663e1579929a2832d24b (diff)
downloadboltzgen_examples-2dba6db0c94ccb260f3e9345b25146ce75ccea9a.tar
boltzgen_examples-2dba6db0c94ccb260f3e9345b25146ce75ccea9a.tar.gz
boltzgen_examples-2dba6db0c94ccb260f3e9345b25146ce75ccea9a.tar.bz2
boltzgen_examples-2dba6db0c94ccb260f3e9345b25146ce75ccea9a.tar.lz
boltzgen_examples-2dba6db0c94ccb260f3e9345b25146ce75ccea9a.tar.xz
boltzgen_examples-2dba6db0c94ccb260f3e9345b25146ce75ccea9a.tar.zst
boltzgen_examples-2dba6db0c94ccb260f3e9345b25146ce75ccea9a.zip
Share boltzgen version between expressions
Diffstat (limited to 'boltzgen.nix')
-rw-r--r--boltzgen.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/boltzgen.nix b/boltzgen.nix
new file mode 100644
index 0000000..74ba512
--- /dev/null
+++ b/boltzgen.nix
@@ -0,0 +1,21 @@
+{ pkgs ? import <nixpkgs> { }, ... }:
+
+let in {
+ boltzgen = python : python.pkgs.buildPythonPackage rec {
+ pname = "boltzgen";
+ version = "0.1";
+
+ src = builtins.fetchGit {
+ url = "https://code.kummerlaender.eu/boltzgen/";
+ rev = "aa509dd4ebbb9d1d8ad6ebfe05111228fd9ae7c0";
+ };
+
+ propagatedBuildInputs = with pkgs.python37Packages; [
+ sympy
+ numpy
+ Mako
+ ];
+
+ doCheck = false;
+ };
+}