aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2016-04-07 16:16:41 +0200
committerAdrian Kummerlaender2016-04-07 16:16:41 +0200
commit8ccbf252e3d3910081de920b2388204e425400c0 (patch)
treebccf24c94efe6c65601ee03fb6e64f052cb65416 /CMakeLists.txt
parent43779dc2b4dffdc75b1b6ca90b49b1e24bbea0fb (diff)
downloadjustify-8ccbf252e3d3910081de920b2388204e425400c0.tar
justify-8ccbf252e3d3910081de920b2388204e425400c0.tar.gz
justify-8ccbf252e3d3910081de920b2388204e425400c0.tar.bz2
justify-8ccbf252e3d3910081de920b2388204e425400c0.tar.lz
justify-8ccbf252e3d3910081de920b2388204e425400c0.tar.xz
justify-8ccbf252e3d3910081de920b2388204e425400c0.tar.zst
justify-8ccbf252e3d3910081de920b2388204e425400c0.zip
Implement proper CLI argument handling using `boost::program_options`
Became necessary due to the introduction of custom line offset as an additional user-defined parameter.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce0a332..656fe91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,11 @@ add_executable(
src/line_accumulator.cc
)
+target_link_libraries(
+ justify
+ boost_program_options
+)
+
install(
TARGETS
justify