aboutsummaryrefslogtreecommitdiff
path: root/custom.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-01-17 15:36:29 +0100
committerAdrian Kummerlaender2020-01-17 15:36:29 +0100
commit40804b0af1814c8d5ea1875283464673b7d3a28c (patch)
tree9eaeb25faa2bcbdb4fd739bade0582738c710f96 /custom.nix
parent9e4f0d3a0d6cae734436c140f0c584557b813c2c (diff)
downloadnixos_home-40804b0af1814c8d5ea1875283464673b7d3a28c.tar
nixos_home-40804b0af1814c8d5ea1875283464673b7d3a28c.tar.gz
nixos_home-40804b0af1814c8d5ea1875283464673b7d3a28c.tar.bz2
nixos_home-40804b0af1814c8d5ea1875283464673b7d3a28c.tar.lz
nixos_home-40804b0af1814c8d5ea1875283464673b7d3a28c.tar.xz
nixos_home-40804b0af1814c8d5ea1875283464673b7d3a28c.tar.zst
nixos_home-40804b0af1814c8d5ea1875283464673b7d3a28c.zip
Implement Jupyter Lab type in Tasker module
Allows for convenient creation of shortcuts to Jupyter Lab sessions. As a bonus they are wrapped in Chromium App View instances and automatically terminated when required.
Diffstat (limited to 'custom.nix')
-rw-r--r--custom.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/custom.nix b/custom.nix
index e489fea..272fc6a 100644
--- a/custom.nix
+++ b/custom.nix
@@ -21,7 +21,7 @@ in {
default = "~/";
};
type = mkOption {
- type = types.enum [ "launcher" "terminal" "local-shell" "local-editor" "environment" "python-console" ];
+ type = types.enum [ "launcher" "terminal" "local-shell" "local-editor" "environment" "python-console" "jupyter-lab" ];
default = "launcher";
};
command = mkOption {
@@ -34,9 +34,23 @@ in {
});
};
+ notebooks = mkOption {
+ type = types.attrsOf (types.submodule {
+ options = {
+ description = mkOption {
+ type = types.uniq types.string;
+ };
+ environment = mkOption {
+ type = types.package;
+ };
+ };
+ });
+ };
+
pkgs = mkOption {
type = types.attrs;
};
+
nixpkgs-unstable = mkOption {
type = types.attrs;
};