aboutsummaryrefslogtreecommitdiff
path: root/custom.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-02-24 17:24:47 +0100
committerAdrian Kummerlaender2019-02-24 17:24:47 +0100
commit68e680721c875c5b677b5c60e754cdf81cc0e909 (patch)
tree7ed5c71e5ed55f4ec54b014f53ad7d8ad3fd771d /custom.nix
parenta9de76d55ac705e8a50decfba2f11e81fe81b294 (diff)
downloadnixos_home-68e680721c875c5b677b5c60e754cdf81cc0e909.tar
nixos_home-68e680721c875c5b677b5c60e754cdf81cc0e909.tar.gz
nixos_home-68e680721c875c5b677b5c60e754cdf81cc0e909.tar.bz2
nixos_home-68e680721c875c5b677b5c60e754cdf81cc0e909.tar.lz
nixos_home-68e680721c875c5b677b5c60e754cdf81cc0e909.tar.xz
nixos_home-68e680721c875c5b677b5c60e754cdf81cc0e909.tar.zst
nixos_home-68e680721c875c5b677b5c60e754cdf81cc0e909.zip
Define type of task entries
Diffstat (limited to 'custom.nix')
-rw-r--r--custom.nix30
1 files changed, 25 insertions, 5 deletions
diff --git a/custom.nix b/custom.nix
index acc8f0e..4928f2a 100644
--- a/custom.nix
+++ b/custom.nix
@@ -1,14 +1,34 @@
{ pkgs, ... }:
-{
+let
+ mkOption = pkgs.lib.mkOption;
+ types = pkgs.lib.types;
+in {
options.custom = {
- hidpi = pkgs.lib.mkOption {
- type = pkgs.lib.types.bool;
+ hidpi = mkOption {
+ type = types.bool;
description = "Configure UI for high DPI displays";
};
- tasks = pkgs.lib.mkOption {
- type = pkgs.lib.types.attrs;
+ tasks = mkOption {
+ type = types.attrsOf (types.submodule {
+ options = {
+ description = mkOption {
+ type = types.uniq types.string;
+ };
+ directory = mkOption {
+ type = types.str;
+ default = "~/";
+ };
+ type = mkOption {
+ type = types.enum [ "launcher" "terminal" ];
+ default = "launcher";
+ };
+ command = mkOption {
+ type = types.str;
+ };
+ };
+ });
};
};
}