aboutsummaryrefslogtreecommitdiff
path: root/custom.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-03-02 20:49:45 +0100
committerAdrian Kummerlaender2019-03-02 20:49:45 +0100
commitf6cdb4a4b050581a257789ab14a9557aba7ff37b (patch)
tree9956e35aa16fc03cb5a7441b768948cdcee5e50b /custom.nix
parentb0725d88eea40e1291b7e42a1e958d1a7e18eba3 (diff)
downloadnixos_home-f6cdb4a4b050581a257789ab14a9557aba7ff37b.tar
nixos_home-f6cdb4a4b050581a257789ab14a9557aba7ff37b.tar.gz
nixos_home-f6cdb4a4b050581a257789ab14a9557aba7ff37b.tar.bz2
nixos_home-f6cdb4a4b050581a257789ab14a9557aba7ff37b.tar.lz
nixos_home-f6cdb4a4b050581a257789ab14a9557aba7ff37b.tar.xz
nixos_home-f6cdb4a4b050581a257789ab14a9557aba7ff37b.tar.zst
nixos_home-f6cdb4a4b050581a257789ab14a9557aba7ff37b.zip
Centrally define set of custom packages
Weirdly I did not find a better way to pass a userspace "<mypkgs>" channel throughout the home-manager expression tree. i.e. adding a "mypkgs ? import <mypkgs> { }" argument to all expressions failed somewhere inside Nix. However this way has the benefit of making it very easy to augment the derivations maintained in pkgs.kummerlaender.eu with additional packages.
Diffstat (limited to 'custom.nix')
-rw-r--r--custom.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/custom.nix b/custom.nix
index 88745ad..61de1aa 100644
--- a/custom.nix
+++ b/custom.nix
@@ -33,5 +33,9 @@ in {
};
});
};
+
+ pkgs = mkOption {
+ type = types.attrs;
+ };
};
}