aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2024-11-23 17:35:33 +0100
committerAdrian Kummerlaender2024-11-23 17:35:33 +0100
commit4bf782b4da3664869c1c790d1fc80b41d435a409 (patch)
tree649d93b43be8b1c8423730865ee518530b6d383d /flake.nix
parent7515de2756c6a997c62de18558f927e62863ed4c (diff)
downloadnixos_home-4bf782b4da3664869c1c790d1fc80b41d435a409.tar
nixos_home-4bf782b4da3664869c1c790d1fc80b41d435a409.tar.gz
nixos_home-4bf782b4da3664869c1c790d1fc80b41d435a409.tar.bz2
nixos_home-4bf782b4da3664869c1c790d1fc80b41d435a409.tar.lz
nixos_home-4bf782b4da3664869c1c790d1fc80b41d435a409.tar.xz
nixos_home-4bf782b4da3664869c1c790d1fc80b41d435a409.tar.zst
nixos_home-4bf782b4da3664869c1c790d1fc80b41d435a409.zip
Update, remove deprecated Jupyter flake
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index e9a3ee2..f0886c7 100644
--- a/flake.nix
+++ b/flake.nix
@@ -10,22 +10,17 @@
inputs = { nixpkgs.follows = "stable"; };
};
emacs.url = github:nix-community/emacs-overlay/master;
- jupyter.url = github:GTrunSec/jupyterWith/flakes;
};
outputs = {
- self, stable, unstable, personal, emacs, home-manager, jupyter, ...
+ self, stable, unstable, personal, emacs, home-manager, ...
}: let
system = "x86_64-linux";
- jupyter-overlay = (final: prev: {
- jupyterWith = jupyter.defaultPackage."${final.system}";
- });
-
pkgs = import stable {
inherit system;
config = { allowUnfree = true; };
- overlays = [ jupyter-overlay emacs.overlay ];
+ overlays = [ emacs.overlay ];
};
pkgs-unstable = import unstable {