aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-08-18 19:02:56 +0200
committerAdrian Kummerlaender2021-08-18 19:02:56 +0200
commitd7376225387e88547ac56409aefb7443af32b7fd (patch)
treecd76aab1c08d31dc4ad18764a77958dc6c6f952b /flake.nix
parent8ec6ada4b1fb7c10b5abda1216daa4502b01ada3 (diff)
downloadnixos_home-d7376225387e88547ac56409aefb7443af32b7fd.tar
nixos_home-d7376225387e88547ac56409aefb7443af32b7fd.tar.gz
nixos_home-d7376225387e88547ac56409aefb7443af32b7fd.tar.bz2
nixos_home-d7376225387e88547ac56409aefb7443af32b7fd.tar.lz
nixos_home-d7376225387e88547ac56409aefb7443af32b7fd.tar.xz
nixos_home-d7376225387e88547ac56409aefb7443af32b7fd.tar.zst
nixos_home-d7376225387e88547ac56409aefb7443af32b7fd.zip
Move jupyterWith to flake inputs
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 1581269..9569468 100644
--- a/flake.nix
+++ b/flake.nix
@@ -13,9 +13,15 @@
url = https://pkgs.kummerlaender.eu/nixexprs.tar.xz;
flake = false;
};
+ jupyter = {
+ url = github:tweag/jupyterWith;
+ flake = false;
+ };
};
- outputs = { self, nixpkgs, nixpkgs-unstable, emacs, home-manager, personal, ... }: let
+ outputs = {
+ self, nixpkgs, nixpkgs-unstable, emacs, home-manager, personal, jupyter, ...
+ }: let
system = "x86_64-linux";
pkgs = import nixpkgs {
@@ -32,6 +38,7 @@
config = { allowUnfree = true; };
overlays = [ emacs.overlay ];
};
+ jupyter = import jupyter { };
};
imports = [ ./home.nix ];
nixpkgs = {