aboutsummaryrefslogtreecommitdiff
path: root/gui/hidpi.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-01-31 20:52:34 +0100
committerAdrian Kummerlaender2019-01-31 20:52:34 +0100
commitb6fb8d0ad3993eccb812750125252dda1764d074 (patch)
tree2f9e8cfafea7b587369d80b688498ef13e9aec5a /gui/hidpi.nix
parent8baa7a0b67be91fe22d6f668440466ab857554c5 (diff)
downloadnixos_home-b6fb8d0ad3993eccb812750125252dda1764d074.tar
nixos_home-b6fb8d0ad3993eccb812750125252dda1764d074.tar.gz
nixos_home-b6fb8d0ad3993eccb812750125252dda1764d074.tar.bz2
nixos_home-b6fb8d0ad3993eccb812750125252dda1764d074.tar.lz
nixos_home-b6fb8d0ad3993eccb812750125252dda1764d074.tar.xz
nixos_home-b6fb8d0ad3993eccb812750125252dda1764d074.tar.zst
nixos_home-b6fb8d0ad3993eccb812750125252dda1764d074.zip
Extract hidpi support
Diffstat (limited to 'gui/hidpi.nix')
-rw-r--r--gui/hidpi.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/gui/hidpi.nix b/gui/hidpi.nix
new file mode 100644
index 0000000..36898e2
--- /dev/null
+++ b/gui/hidpi.nix
@@ -0,0 +1,27 @@
+{ pkgs, ... }:
+
+{
+ home.sessionVariables = {
+ GDK_SCALE = "2";
+ GDK_DPI_SCALE = "0.5";
+ };
+
+ xresources.extraConfig = ''
+ Xft.dpi: 160
+ Xft.autohint: 0
+ Xft.lcdfilter: lcddefault
+ Xft.hintstyle: hintfull
+ Xft.hinting: 1
+ Xft.antialias: 1
+ Xft.rgba: rgb
+ '';
+
+ home.file.".config/twmn/twmn.conf".text = ''
+ font_size=24
+ height=32
+ '';
+
+ programs.rofi.extraConfig = ''
+ rofi.dpi: 160
+ '';
+}