aboutsummaryrefslogtreecommitdiff
path: root/gui/pkgs/oomox-archdroid-icon-theme.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-05-05 13:02:04 +0200
committerAdrian Kummerlaender2018-05-05 13:02:04 +0200
commitdea9a66fccca94ed27387246e384f3dcb20501f6 (patch)
tree06ed6657b0d014d5e8faa0a20b267bf6a9f34472 /gui/pkgs/oomox-archdroid-icon-theme.nix
parent74951f7eb0d8914201a5a4fa1b534abfe0ecfa0d (diff)
downloadnixos_home-dea9a66fccca94ed27387246e384f3dcb20501f6.tar
nixos_home-dea9a66fccca94ed27387246e384f3dcb20501f6.tar.gz
nixos_home-dea9a66fccca94ed27387246e384f3dcb20501f6.tar.bz2
nixos_home-dea9a66fccca94ed27387246e384f3dcb20501f6.tar.lz
nixos_home-dea9a66fccca94ed27387246e384f3dcb20501f6.tar.xz
nixos_home-dea9a66fccca94ed27387246e384f3dcb20501f6.tar.zst
nixos_home-dea9a66fccca94ed27387246e384f3dcb20501f6.zip
Basic attempt at a better structure
Diffstat (limited to 'gui/pkgs/oomox-archdroid-icon-theme.nix')
-rw-r--r--gui/pkgs/oomox-archdroid-icon-theme.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/gui/pkgs/oomox-archdroid-icon-theme.nix b/gui/pkgs/oomox-archdroid-icon-theme.nix
new file mode 100644
index 0000000..764bf2f
--- /dev/null
+++ b/gui/pkgs/oomox-archdroid-icon-theme.nix
@@ -0,0 +1,29 @@
+{ stdenv, pkgs, color, ... }:
+
+stdenv.mkDerivation rec {
+ name = "oomox-archdroid-icon-theme";
+
+ src = pkgs.fetchFromGitHub {
+ repo = "archdroid-icon-theme";
+ owner = "themix-project";
+ rev = "6dc4c92689ea2ce99534d6f461283efdf8ffd270";
+ sha256 = "073iwaamzrmj0l6h4gzmbnmazq16lgpc027mr3l778b35qwwraq5";
+ };
+
+ postPatch = ''
+ patchShebangs .
+ '';
+
+ installPhase = ''
+ HOME="$out/share/icons"
+ sed -i "66s/\.icons\///" change_color.sh
+ ./change_color.sh --output oomox-archdroid --color ${color}
+ '';
+
+ meta = {
+ description = "oomox-archdroid-icon-theme is a customizable fork of archdroid-icon-theme";
+ homepage = https://github.com/themix-project/archdroid-icon-theme;
+ license = stdenv.lib.licenses.gpl3;
+ platforms = stdenv.lib.platforms.all;
+ };
+}