aboutsummaryrefslogtreecommitdiff
path: root/gui/tasker.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-02-22 20:34:18 +0100
committerAdrian Kummerlaender2019-02-22 20:34:18 +0100
commit4bda7bcd1eb2410ff7466fd4da2b5345ece6763f (patch)
tree167e374e350978c175747de0b7b522dc27543ae1 /gui/tasker.nix
parent0b2cde8591776d58333b07062748606d91a9f1db (diff)
downloadnixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.gz
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.bz2
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.lz
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.xz
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.zst
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.zip
Declare tasks as attribute option
This way it is easy to support e.g. host specific tasks
Diffstat (limited to 'gui/tasker.nix')
-rw-r--r--gui/tasker.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/gui/tasker.nix b/gui/tasker.nix
deleted file mode 100644
index e7092ba..0000000
--- a/gui/tasker.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ pkgs, ... }:
-
-let
- tasks = {
- "bsc_edit" = {
- description = "Grid refinement BSc thesis editor";
- directory = "~/university/documents/bachelor/arbeit";
- terminal = false;
- command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
- };
- "bsc_shell" = {
- description = "Grid refinement BSc thesis shell";
- directory = "~/university/documents/bachelor/arbeit";
- terminal = true;
- command = "nix-shell --command fish";
- };
- "bsc_view" = {
- description = "Grid refinement BSc thesis PDF";
- directory = "~/university/documents/bachelor/arbeit";
- terminal = false;
- command = "evince build/main.pdf";
- };
- "olb_edit" = {
- description = "OpenLB editor";
- directory = "~/projects/contrib/openlb";
- terminal = false;
- command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
- };
- "olb_shell" = {
- description = "OpenLB shell";
- directory = "~/projects/contrib/openlb";
- terminal = true;
- command = "nix-shell --command fish";
- };
- };
-in {
- home.packages = pkgs.callPackage ./pkgs/tasker.nix { inherit pkgs; inherit tasks; };
-}