aboutsummaryrefslogtreecommitdiff
path: root/gui/touchegg.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2022-02-01 23:40:17 +0100
committerAdrian Kummerlaender2022-02-01 23:40:17 +0100
commit44434920a92a2e47a26e075e6ac9fea01c24bd70 (patch)
tree69a3e9e73ea9929d04935ae640cb27192c14ec29 /gui/touchegg.nix
parent716eb7c399631df86f8993db6c5ea27a90f6298b (diff)
downloadnixos_home-44434920a92a2e47a26e075e6ac9fea01c24bd70.tar
nixos_home-44434920a92a2e47a26e075e6ac9fea01c24bd70.tar.gz
nixos_home-44434920a92a2e47a26e075e6ac9fea01c24bd70.tar.bz2
nixos_home-44434920a92a2e47a26e075e6ac9fea01c24bd70.tar.lz
nixos_home-44434920a92a2e47a26e075e6ac9fea01c24bd70.tar.xz
nixos_home-44434920a92a2e47a26e075e6ac9fea01c24bd70.tar.zst
nixos_home-44434920a92a2e47a26e075e6ac9fea01c24bd70.zip
Update athena config
Diffstat (limited to 'gui/touchegg.nix')
-rw-r--r--gui/touchegg.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/gui/touchegg.nix b/gui/touchegg.nix
deleted file mode 100644
index 8e5cb6b..0000000
--- a/gui/touchegg.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ pkgs, ... }:
-
-{
- home.file.".config/touchegg/touchegg.conf".text = let
- uictrl = pkgs.lib.callPackageWith pkgs ./pkgs/uictrl.nix { };
- in ''
- <touchégg>
- <application name="All">
- <gesture type="DRAG" fingers="3" direction="LEFT">
- <action type="RUN_COMMAND">${uictrl}/bin/uictrl next</action>
- </gesture>
- <gesture type="DRAG" fingers="3" direction="RIGHT">
- <action type="RUN_COMMAND">${uictrl}/bin/uictrl prev</action>
- </gesture>
- <gesture type="TAP" fingers="2">
- <action type="MOUSE_CLICK">BUTTON=3</action>
- </gesture>
- </application>
- </touchégg>
- '';
-
- systemd.user.services.touchegg = {
- Unit = {
- Description = "Touchégg multitouch gestures";
- After = [ "graphical-session-pre.target" ];
- PartOf = [ "graphical-session.target" ];
- };
-
- Install = {
- WantedBy = [ "graphical-session.target" ];
- };
-
- Service = {
- ExecStart = "${pkgs.touchegg}/bin/touchegg";
- Restart = "on-failure";
- };
- };
-}