aboutsummaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-08-19 23:33:53 +0200
committerAdrian Kummerlaender2021-08-19 23:33:53 +0200
commit14e72c5f239dd02234cbe467c3a4be1c0845c7cd (patch)
treeffbfe47590e3e74c54e145e76e7da0832e33e4d1 /home.nix
parentd7376225387e88547ac56409aefb7443af32b7fd (diff)
downloadnixos_home-14e72c5f239dd02234cbe467c3a4be1c0845c7cd.tar
nixos_home-14e72c5f239dd02234cbe467c3a4be1c0845c7cd.tar.gz
nixos_home-14e72c5f239dd02234cbe467c3a4be1c0845c7cd.tar.bz2
nixos_home-14e72c5f239dd02234cbe467c3a4be1c0845c7cd.tar.lz
nixos_home-14e72c5f239dd02234cbe467c3a4be1c0845c7cd.tar.xz
nixos_home-14e72c5f239dd02234cbe467c3a4be1c0845c7cd.tar.zst
nixos_home-14e72c5f239dd02234cbe467c3a4be1c0845c7cd.zip
Enable pure instantiation of config via flake
i.e. via `nix run .#hostname`. Currently pulling in a pending pull request at jupyterWith for flakeified JupyterLab installations. The entire system consisting of `nixos_system` and `nixos_home` flakes can now be purely instantiated from clones in the user directory. No "/etc/nixos" resp. ".config/nixpkgs" needed. This is nice, probably not going to bother merging both repositories.
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/home.nix b/home.nix
index 27a9bba..5589325 100644
--- a/home.nix
+++ b/home.nix
@@ -1,10 +1,7 @@
-{ config, pkgs, pkgs-personal, ... }:
+{ config, pkgs, pkgs-personal, hostname, ... }:
{
- imports = let
- # impure access to system config
- hostname = (import <nixpkgs/nixos> { }).config.networking.hostName;
- in [
+ imports = [
# define options custom to this config
./custom.nix
# load host specific stuff