aboutsummaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-08-27 21:10:56 +0200
committerAdrian Kummerlaender2020-08-27 21:10:56 +0200
commit290c1c8116cd70cc248cf4bb9458611a16c5694a (patch)
tree7a2e824dd593e31ba5878b419460d543473d85a3 /home.nix
parent191438718de6175cb0cff457005ed312cc4e8fd8 (diff)
downloadnixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.gz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.bz2
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.lz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.xz
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.tar.zst
nixos_home-290c1c8116cd70cc248cf4bb9458611a16c5694a.zip
Use niv for tracking channel versions
This way the config is actually reproducible without manually tracking supported nixpkgs states. home-manager is now not installed environment-wide anymore but only available inside a nix-shell.
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/home.nix b/home.nix
index 20f9bc9..40f0a2e 100644
--- a/home.nix
+++ b/home.nix
@@ -1,9 +1,16 @@
{ config, pkgs, ... }:
-{
- custom.pkgs = import <mypkgs> { };
- custom.nixpkgs-unstable = import <nixpkgs-unstable> { };
+let
+ sources = import ./nix/sources.nix;
+ pkgs = import sources.nixpkgs { };
+ pkgs-unstable = import sources.nixpkgs-unstable { };
+ pkgs-personal = import sources.mypkgs { };
+in {
+ _module.args.sources = sources;
+ _module.args.pkgs-unstable = pkgs-unstable;
+ _module.args.pkgs-personal = pkgs-personal;
+
imports = [
# define options custom to this config
./custom.nix
@@ -18,7 +25,7 @@
keyboard.layout = "de";
packages = [
- config.custom.pkgs.persistent-nix-shell
+ pkgs-personal.persistent-nix-shell
];
};