aboutsummaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-04-23 20:38:31 +0200
committerAdrian Kummerlaender2018-04-23 20:38:31 +0200
commit7b9579d8559accb1f8e03b336de5edec9e78adbf (patch)
treedef5acdeaed8c0000070f25a8fccc43e2a5fd366 /home.nix
parentbadeadd8e7f3b0068c37d3695b6367d745329411 (diff)
downloadnixos_home-7b9579d8559accb1f8e03b336de5edec9e78adbf.tar
nixos_home-7b9579d8559accb1f8e03b336de5edec9e78adbf.tar.gz
nixos_home-7b9579d8559accb1f8e03b336de5edec9e78adbf.tar.bz2
nixos_home-7b9579d8559accb1f8e03b336de5edec9e78adbf.tar.lz
nixos_home-7b9579d8559accb1f8e03b336de5edec9e78adbf.tar.xz
nixos_home-7b9579d8559accb1f8e03b336de5edec9e78adbf.tar.zst
nixos_home-7b9579d8559accb1f8e03b336de5edec9e78adbf.zip
Add basic oomox-gtk-theme derivation
For my current laptop configuration I maintain a custom GTK theme to match i3 and vim color schemes (see KnairdA/dotfiles). As starting point I want to port this setup to NixOS and XMonad. The objective is to get to a point where I can change accent colors in a central location (i.e. some Nix file) and generate everything else automatically. The included derivation builds and installs this custom oomox generated theme in a quick and dirty fashion. This can definitely be improved in many ways, e.g. splitting the config into Nix params. The result looks mostly correct - remaining differences are probably due to the missing Icon theme. Additionally I had to define $HOME as oomox seems to attempt to write there in spite of the target directory definition. Note that this derivation currently only builds on unstable as older versions of sassc terminate with some kind of CSS error. Luckily this is no problem for Nix.
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/home.nix b/home.nix
index 8325fa7..afcbc15 100644
--- a/home.nix
+++ b/home.nix
@@ -74,6 +74,20 @@
xresources.extraConfig = builtins.readFile ./conf/urxvt.Xresources;
+ gtk = {
+ enable = true;
+
+ theme = {
+ name = "oomox";
+ package = import ./pkgs/oomox-gtk-theme.nix;
+ };
+
+ gtk2.extraConfig = ''
+ style "vimfix" { bg[NORMAL] = "#161616" }
+ widget "vim-main-window.*GtkForm" style "vimfix"
+ '';
+ };
+
programs.rofi = {
enable = true;
location = "top";