aboutsummaryrefslogtreecommitdiff
path: root/custom.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom.nix')
-rw-r--r--custom.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/custom.nix b/custom.nix
index e489fea..272fc6a 100644
--- a/custom.nix
+++ b/custom.nix
@@ -21,7 +21,7 @@ in {
default = "~/";
};
type = mkOption {
- type = types.enum [ "launcher" "terminal" "local-shell" "local-editor" "environment" "python-console" ];
+ type = types.enum [ "launcher" "terminal" "local-shell" "local-editor" "environment" "python-console" "jupyter-lab" ];
default = "launcher";
};
command = mkOption {
@@ -34,9 +34,23 @@ in {
});
};
+ notebooks = mkOption {
+ type = types.attrsOf (types.submodule {
+ options = {
+ description = mkOption {
+ type = types.uniq types.string;
+ };
+ environment = mkOption {
+ type = types.package;
+ };
+ };
+ });
+ };
+
pkgs = mkOption {
type = types.attrs;
};
+
nixpkgs-unstable = mkOption {
type = types.attrs;
};