aboutsummaryrefslogtreecommitdiff
path: root/custom.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom.nix')
-rw-r--r--custom.nix30
1 files changed, 25 insertions, 5 deletions
diff --git a/custom.nix b/custom.nix
index acc8f0e..4928f2a 100644
--- a/custom.nix
+++ b/custom.nix
@@ -1,14 +1,34 @@
{ pkgs, ... }:
-{
+let
+ mkOption = pkgs.lib.mkOption;
+ types = pkgs.lib.types;
+in {
options.custom = {
- hidpi = pkgs.lib.mkOption {
- type = pkgs.lib.types.bool;
+ hidpi = mkOption {
+ type = types.bool;
description = "Configure UI for high DPI displays";
};
- tasks = pkgs.lib.mkOption {
- type = pkgs.lib.types.attrs;
+ tasks = mkOption {
+ type = types.attrsOf (types.submodule {
+ options = {
+ description = mkOption {
+ type = types.uniq types.string;
+ };
+ directory = mkOption {
+ type = types.str;
+ default = "~/";
+ };
+ type = mkOption {
+ type = types.enum [ "launcher" "terminal" ];
+ default = "launcher";
+ };
+ command = mkOption {
+ type = types.str;
+ };
+ };
+ });
};
};
}