aboutsummaryrefslogtreecommitdiff
path: root/custom.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom.nix')
-rw-r--r--custom.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/custom.nix b/custom.nix
index 4928f2a..06b6676 100644
--- a/custom.nix
+++ b/custom.nix
@@ -21,12 +21,15 @@ in {
default = "~/";
};
type = mkOption {
- type = types.enum [ "launcher" "terminal" ];
+ type = types.enum [ "launcher" "terminal" "environment" ];
default = "launcher";
};
command = mkOption {
type = types.str;
};
+ environment = mkOption {
+ type = types.package;
+ };
};
});
};