aboutsummaryrefslogtreecommitdiff
path: root/custom.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-02-24 21:02:29 +0100
committerAdrian Kummerlaender2019-02-24 21:02:29 +0100
commitf87582250fd324cd04886cd84a7ee58d03133b13 (patch)
tree6e49ead9beb5a806d6525ea0f8e0034ccb34346c /custom.nix
parent68e680721c875c5b677b5c60e754cdf81cc0e909 (diff)
downloadnixos_home-f87582250fd324cd04886cd84a7ee58d03133b13.tar
nixos_home-f87582250fd324cd04886cd84a7ee58d03133b13.tar.gz
nixos_home-f87582250fd324cd04886cd84a7ee58d03133b13.tar.bz2
nixos_home-f87582250fd324cd04886cd84a7ee58d03133b13.tar.lz
nixos_home-f87582250fd324cd04886cd84a7ee58d03133b13.tar.xz
nixos_home-f87582250fd324cd04886cd84a7ee58d03133b13.tar.zst
nixos_home-f87582250fd324cd04886cd84a7ee58d03133b13.zip
Add nix-shell environment type to tasker
Allows for convenient management of non-project-specific shell environments.
Diffstat (limited to 'custom.nix')
-rw-r--r--custom.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/custom.nix b/custom.nix
index 4928f2a..06b6676 100644
--- a/custom.nix
+++ b/custom.nix
@@ -21,12 +21,15 @@ in {
default = "~/";
};
type = mkOption {
- type = types.enum [ "launcher" "terminal" ];
+ type = types.enum [ "launcher" "terminal" "environment" ];
default = "launcher";
};
command = mkOption {
type = types.str;
};
+ environment = mkOption {
+ type = types.package;
+ };
};
});
};