aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 4 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index e9a3ee2..f9beadb 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,30 +2,25 @@
description = "Computing environment of Adrian Kummerlaender";
inputs = {
- stable.url = github:NixOS/nixpkgs/nixos-24.05;
+ stable.url = github:NixOS/nixpkgs/nixos-24.11;
unstable.url = github:NixOS/nixpkgs/nixpkgs-unstable;
personal.url = github:KnairdA/pkgs;
home-manager = {
- url = github:nix-community/home-manager/release-24.05;
+ url = github:nix-community/home-manager/release-24.11;
inputs = { nixpkgs.follows = "stable"; };
};
emacs.url = github:nix-community/emacs-overlay/master;
- jupyter.url = github:GTrunSec/jupyterWith/flakes;
};
outputs = {
- self, stable, unstable, personal, emacs, home-manager, jupyter, ...
+ self, stable, unstable, personal, emacs, home-manager, ...
}: let
system = "x86_64-linux";
- jupyter-overlay = (final: prev: {
- jupyterWith = jupyter.defaultPackage."${final.system}";
- });
-
pkgs = import stable {
inherit system;
config = { allowUnfree = true; };
- overlays = [ jupyter-overlay emacs.overlay ];
+ overlays = [ emacs.overlay ];
};
pkgs-unstable = import unstable {