aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix39
1 files changed, 22 insertions, 17 deletions
diff --git a/flake.nix b/flake.nix
index 7388919..1581269 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,27 +23,32 @@
config = { allowUnfree = true; };
};
- in {
- homeManagerConfigurations = {
- common = home-manager.lib.homeManagerConfiguration {
- configuration = { pkgs, ... }: {
- _module.args = {
- pkgs-personal = import personal { };
- pkgs-unstable = import nixpkgs-unstable {
- inherit system;
- config = { allowUnfree = true; };
- overlays = [ emacs.overlay ];
- };
- };
- imports = [ ./home.nix ];
- nixpkgs = {
+ home = home-manager.lib.homeManagerConfiguration {
+ configuration = { pkgs, ... }: {
+ _module.args = {
+ pkgs-personal = import personal { };
+ pkgs-unstable = import nixpkgs-unstable {
+ inherit system;
config = { allowUnfree = true; };
+ overlays = [ emacs.overlay ];
};
};
- system = system;
- homeDirectory = "/home/common";
- username = "common";
+ imports = [ ./home.nix ];
+ nixpkgs = {
+ config = { allowUnfree = true; };
+ };
};
+ system = system;
+ homeDirectory = "/home/common";
+ username = "common";
+ };
+
+ in {
+ defaultPackage.x86_64-linux = home.activationPackage;
+
+ defaultApp.x86_64-linux = {
+ type = "app";
+ program = "${home.activationPackage}/activate";
};
};
}