aboutsummaryrefslogtreecommitdiff
path: root/gui/hidpi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/hidpi.nix')
-rw-r--r--gui/hidpi.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/gui/hidpi.nix b/gui/hidpi.nix
new file mode 100644
index 0000000..5ea63c2
--- /dev/null
+++ b/gui/hidpi.nix
@@ -0,0 +1,28 @@
+{ pkgs, ... }:
+
+{
+ home.sessionVariables = {
+ GDK_SCALE = "2";
+ GDK_DPI_SCALE = "0.5";
+ };
+
+ xresources.extraConfig = ''
+ Xft.dpi: 160
+ Xft.autohint: 0
+ Xft.lcdfilter: lcddefault
+ Xft.hintstyle: hintfull
+ Xft.hinting: 1
+ Xft.antialias: 1
+ Xft.rgba: rgb
+ '';
+
+ home.file.".config/twmn/twmn.conf".text = ''
+ [gui]
+ font_size=24
+ height=32
+ '';
+
+ programs.rofi.extraConfig = ''
+ rofi.dpi: 160
+ '';
+}