aboutsummaryrefslogtreecommitdiff
path: root/gui/qtile.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/qtile.nix')
-rw-r--r--gui/qtile.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/gui/qtile.nix b/gui/qtile.nix
new file mode 100644
index 0000000..12aa042
--- /dev/null
+++ b/gui/qtile.nix
@@ -0,0 +1,40 @@
+{ config, pkgs, ... }:
+
+let
+ hidpi = config.custom.hidpi;
+
+in {
+ imports = [
+ ./gtk.nix
+ ./rofi.nix
+ ./twmn.nix
+ ];
+
+ xsession = {
+ enable = true;
+
+ pointerCursor = {
+ package = pkgs.vanilla-dmz;
+ name = "Vanilla-DMZ-AA";
+ size = if hidpi then 48 else 16;
+ };
+
+ windowManager.command = "qtile";
+ };
+
+ home.packages = with pkgs; [
+ # wm
+ qtile
+ # lockscreen
+ i3lock
+ ];
+
+ home.file.".config/qtile/config.py".source = ./conf/qtile.py;
+
+ services.screen-locker = {
+ enable = true;
+ lockCmd = "${pkgs.i3lock}/bin/i3lock -n -c 000000";
+ };
+
+ services.flameshot.enable = true;
+}