aboutsummaryrefslogtreecommitdiff
path: root/gui/tasker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/tasker.nix')
-rw-r--r--gui/tasker.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/gui/tasker.nix b/gui/tasker.nix
deleted file mode 100644
index e7092ba..0000000
--- a/gui/tasker.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ pkgs, ... }:
-
-let
- tasks = {
- "bsc_edit" = {
- description = "Grid refinement BSc thesis editor";
- directory = "~/university/documents/bachelor/arbeit";
- terminal = false;
- command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
- };
- "bsc_shell" = {
- description = "Grid refinement BSc thesis shell";
- directory = "~/university/documents/bachelor/arbeit";
- terminal = true;
- command = "nix-shell --command fish";
- };
- "bsc_view" = {
- description = "Grid refinement BSc thesis PDF";
- directory = "~/university/documents/bachelor/arbeit";
- terminal = false;
- command = "evince build/main.pdf";
- };
- "olb_edit" = {
- description = "OpenLB editor";
- directory = "~/projects/contrib/openlb";
- terminal = false;
- command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
- };
- "olb_shell" = {
- description = "OpenLB shell";
- directory = "~/projects/contrib/openlb";
- terminal = true;
- command = "nix-shell --command fish";
- };
- };
-in {
- home.packages = pkgs.callPackage ./pkgs/tasker.nix { inherit pkgs; inherit tasks; };
-}