aboutsummaryrefslogtreecommitdiff
path: root/gui/tasker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/tasker.nix')
-rw-r--r--gui/tasker.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/gui/tasker.nix b/gui/tasker.nix
new file mode 100644
index 0000000..bb006fa
--- /dev/null
+++ b/gui/tasker.nix
@@ -0,0 +1,20 @@
+{ pkgs, ... }:
+
+let
+ tasks = {
+ "bsc_edit" = {
+ description = "Grid refinement BSc thesis editor";
+ directory = "~/university/documents/bachelor/arbeit";
+ command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
+ };
+ "bsc_view" = {
+ description = "Grid refinement BSc thesis PDF";
+ directory = "~/university/documents/bachelor/arbeit";
+ command = "evince build/main.pdf";
+ };
+ };
+in {
+ home.packages = let
+ task_derivations = pkgs.callPackage ./pkgs/tasker.nix { inherit pkgs; inherit tasks; };
+ in task_derivations;
+}