aboutsummaryrefslogtreecommitdiff
path: root/gui/tasker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/tasker.nix')
-rw-r--r--gui/tasker.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/gui/tasker.nix b/gui/tasker.nix
index 0805ac8..43a40df 100644
--- a/gui/tasker.nix
+++ b/gui/tasker.nix
@@ -5,11 +5,19 @@ let
"bsc_edit" = {
description = "Grid refinement BSc thesis editor";
directory = "~/university/documents/bachelor/arbeit";
+ terminal = false;
command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
};
+ "bsc_shell" = {
+ description = "Grid refinement BSc thesis shell";
+ directory = "~/university/documents/bachelor/arbeit";
+ terminal = true;
+ command = "nix-shell --command fish";
+ };
"bsc_view" = {
description = "Grid refinement BSc thesis PDF";
directory = "~/university/documents/bachelor/arbeit";
+ terminal = false;
command = "evince build/main.pdf";
};
};