aboutsummaryrefslogtreecommitdiff
path: root/gui/touchegg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/touchegg.nix')
-rw-r--r--gui/touchegg.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/gui/touchegg.nix b/gui/touchegg.nix
new file mode 100644
index 0000000..1455da8
--- /dev/null
+++ b/gui/touchegg.nix
@@ -0,0 +1,22 @@
+{ pkgs, ... }:
+
+{
+ home.file.".config/touchegg/touchegg.conf".source = ./conf/touchegg.conf;
+
+ systemd.user.services.touchegg = {
+ Unit = {
+ Description = "Touchégg multitouch gestures";
+ After = [ "graphical-session-pre.target" ];
+ PartOf = [ "graphical-session.target" ];
+ };
+
+ Install = {
+ WantedBy = [ "graphical-session.target" ];
+ };
+
+ Service = {
+ ExecStart = "${pkgs.touchegg}/bin/touchegg";
+ Restart = "on-failure";
+ };
+ };
+}