aboutsummaryrefslogtreecommitdiff
path: root/gui/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/vim.nix')
-rw-r--r--gui/vim.nix22
1 files changed, 4 insertions, 18 deletions
diff --git a/gui/vim.nix b/gui/vim.nix
index 46ab079..b9189c1 100644
--- a/gui/vim.nix
+++ b/gui/vim.nix
@@ -2,18 +2,12 @@
{
home = {
- # vim is configured globally for all users but common is the only GUI user
- file.".gvimrc".text = ''
- set guifont=Iosevka\ 10
- set linespace=2
- set guioptions=agi
- '';
-
- # nvim-qt using vim configuration
packages = let
- nvim-gui = import ./pkgs/nvim-gui.nix { inherit pkgs config; };
+ neovim-qt = pkgs.neovim-qt.override {
+ neovim = config.custom.pkgs.custom-neovim;
+ };
in [
- nvim-gui
+ neovim-qt
pkgs.xclip # required to access clipboard in nvim-gui
];
@@ -25,14 +19,6 @@
'';
};
- gtk = {
- gtk3.extraCss = ''
- window#vim-main-window {
- background-color: #161616;
- }
- '';
- };
-
programs.fish = {
enable = true;
shellAliases = {