aboutsummaryrefslogtreecommitdiff
path: root/gui/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/vim.nix')
-rw-r--r--gui/vim.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/gui/vim.nix b/gui/vim.nix
deleted file mode 100644
index 27f2e5a..0000000
--- a/gui/vim.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- home = {
- packages = let
- neovim-qt = pkgs.neovim-qt.override {
- neovim = config.custom.pkgs.custom-neovim;
- };
- in [
- neovim-qt
- pkgs.xclip # required to access clipboard in nvim-gui
- pkgs.fzf # required for all kinds of narrow-down-completion
- ];
-
- file.".config/nvim/ginit.vim".text = ''
- set title
- Guifont! Iosevka:h10
- set guifont=Iosevka:h10
- autocmd FocusGained * :checktime
- '';
- };
-
- programs.fish = {
- enable = true;
- shellAliases = {
- nvim-qt = "nvim-qt --no-ext-tabline ^ /dev/null > /dev/null";
- };
- };
-}