aboutsummaryrefslogtreecommitdiff
path: root/gui/xmonad.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/xmonad.nix')
-rw-r--r--gui/xmonad.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/gui/xmonad.nix b/gui/xmonad.nix
index 85f86c2..da7d73a 100644
--- a/gui/xmonad.nix
+++ b/gui/xmonad.nix
@@ -1,9 +1,19 @@
{ pkgs, ... }:
{
- xsession.windowManager.xmonad = {
+ xsession = {
enable = true;
- enableContribAndExtras = true;
- config = ./conf/xmonad.hs;
+
+ pointerCursor = {
+ package = pkgs.vanilla-dmz;
+ name = "Vanilla-DMZ-AA";
+ size = 16;
+ };
+
+ windowManager.xmonad = {
+ enable = true;
+ enableContribAndExtras = true;
+ config = ./conf/xmonad.hs;
+ };
};
}