aboutsummaryrefslogtreecommitdiff
path: root/tasks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tasks/default.nix')
-rw-r--r--tasks/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tasks/default.nix b/tasks/default.nix
index 075af56..2d76551 100644
--- a/tasks/default.nix
+++ b/tasks/default.nix
@@ -1,4 +1,4 @@
-{ pkgs, jupyter, ... }:
+{ pkgs, ... }:
let
mkShellDerivation = n: ps: pkgs.stdenvNoCC.mkDerivation rec {
@@ -27,7 +27,7 @@ let
'';
};
- mkJupyterEnv = kernel: jupyter.jupyterlabWith {
+ mkJupyterEnv = kernel: pkgs.jupyterWith.jupyterlabWith {
kernels = [ kernel ];
};
@@ -59,7 +59,7 @@ in {
directory = "~/";
type = "jupyter-lab";
environment = mkJupyterEnv (
- jupyter.kernels.iPythonWith {
+ pkgs.jupyterWith.kernels.iPythonWith {
name = "python";
packages = p: with p; [
numpy