aboutsummaryrefslogtreecommitdiff
path: root/tasks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tasks/default.nix')
-rw-r--r--tasks/default.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/tasks/default.nix b/tasks/default.nix
index 6966fd2..3af769f 100644
--- a/tasks/default.nix
+++ b/tasks/default.nix
@@ -14,34 +14,37 @@ in {
bsc_edit = {
description = "Grid refinement BSc thesis editor";
directory = "~/university/documents/bachelor/arbeit";
- command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
+ type = "local-editor";
};
+
bsc_shell = {
description = "Grid refinement BSc thesis shell";
- type = "terminal";
directory = "~/university/documents/bachelor/arbeit";
- command = "nix-shell --command fish";
+ type = "local-shell";
};
+
bsc_view = {
description = "Grid refinement BSc thesis PDF";
directory = "~/university/documents/bachelor/arbeit";
command = "evince build/main.pdf";
};
+
olb_edit = {
description = "OpenLB editor";
directory = "~/projects/contrib/openlb";
- command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
+ type = "local-editor";
};
+
olb_shell = {
description = "OpenLB shell";
- type = "terminal";
directory = "~/projects/contrib/openlb";
- command = "nix-shell --command fish";
+ type = "local-shell";
};
+
cpp_shell = {
description = "Generic C++ shell environment";
- type = "environment";
directory = "~/";
+ type = "environment";
environment = mkShellDerivation "cpp-env" (with pkgs; [
cmake
gcc8