aboutsummaryrefslogtreecommitdiff
path: root/tasks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tasks/default.nix')
-rw-r--r--tasks/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/tasks/default.nix b/tasks/default.nix
new file mode 100644
index 0000000..9fbee61
--- /dev/null
+++ b/tasks/default.nix
@@ -0,0 +1,36 @@
+{ ... }:
+
+{
+ custom.tasks = {
+ "bsc_edit" = {
+ description = "Grid refinement BSc thesis editor";
+ directory = "~/university/documents/bachelor/arbeit";
+ terminal = false;
+ command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
+ };
+ "bsc_shell" = {
+ description = "Grid refinement BSc thesis shell";
+ directory = "~/university/documents/bachelor/arbeit";
+ terminal = true;
+ command = "nix-shell --command fish";
+ };
+ "bsc_view" = {
+ description = "Grid refinement BSc thesis PDF";
+ directory = "~/university/documents/bachelor/arbeit";
+ terminal = false;
+ command = "evince build/main.pdf";
+ };
+ "olb_edit" = {
+ description = "OpenLB editor";
+ directory = "~/projects/contrib/openlb";
+ terminal = false;
+ command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
+ };
+ "olb_shell" = {
+ description = "OpenLB shell";
+ directory = "~/projects/contrib/openlb";
+ terminal = true;
+ command = "nix-shell --command fish";
+ };
+ };
+}