aboutsummaryrefslogtreecommitdiff
path: root/tasks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tasks/default.nix')
-rw-r--r--tasks/default.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/tasks/default.nix b/tasks/default.nix
index 9e641c3..04013c2 100644
--- a/tasks/default.nix
+++ b/tasks/default.nix
@@ -12,7 +12,6 @@ let
mkPythonShellDerivation = n: ps: init: pkgs.stdenvNoCC.mkDerivation rec {
name = n;
buildInputs = [(pkgs.python3.withPackages (python-packages: with python-packages; ps ++ [
- jupyterlab
qtconsole
]))];
shellHook = let
@@ -27,10 +26,6 @@ let
'';
};
- mkJupyterEnv = kernel: pkgs.jupyterWith.jupyterlabWith {
- kernels = [ kernel ];
- };
-
in {
custom.tasks = {
cpp_shell = {
@@ -64,22 +59,5 @@ in {
biber
]);
};
-
- pymath_jupyter = {
- description = "Python for mathematics @ Jupyter Lab";
- directory = "~/";
- type = "jupyter-lab";
- environment = mkJupyterEnv (
- pkgs.jupyterWith.kernels.iPythonWith {
- name = "python";
- packages = p: with p; [
- numpy
- sympy
- scipy
- matplotlib
- ];
- }
- );
- };
};
}