aboutsummaryrefslogtreecommitdiff
path: root/tasks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tasks/default.nix')
-rw-r--r--tasks/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tasks/default.nix b/tasks/default.nix
index 3af769f..6b891dd 100644
--- a/tasks/default.nix
+++ b/tasks/default.nix
@@ -51,5 +51,18 @@ in {
gdb cgdb
]);
};
+
+ latex_shell = {
+ description = "Generic LaTeX shell environment";
+ directory = "~/";
+ type = "environment";
+ environment = with pkgs; let
+ texlive-custom = texlive.combine {
+ inherit (texlive) scheme-small collection-langgerman latexmk amsmath enumitem;
+ };
+ in mkShellDerivation "latex-env" [
+ texlive-custom
+ ];
+ };
};
}